Heavily Degraded Site Performance & Unavailability
Incident Report for Clay
Resolved
This incident has been resolved.
Posted May 14, 2024 - 15:59 UTC
Monitoring
API and site behavior has normalized. We're monitoring the system's performance and availability.
Posted May 14, 2024 - 14:31 UTC
Update
We've identified that our database is under high load. We've taken some actions to mitigate the load to get the site back online.
Posted May 14, 2024 - 14:23 UTC
Investigating
We are currently investigating this issue.
Posted May 14, 2024 - 11:30 UTC
This incident affected: Core (Web app, API).